Access Bedienungsanleitung: Aktivieren des Sicherungssystems durch Erstellen einer Arbeitsgruppendatei

Aus DBWiki
Wechseln zu: Navigation, Suche

Problem

Ich möchte das Sicherungssystem von Access aktivieren, um meinen Code und meine erstellten Objekte vor dem Zugriff anderer Benutzer zu schützen.

Lösung (für Access 2000)

Das geht durch die folgenden Arbeitsschritte:

  1. Erstellen einer neuen Arbeitsgruppen-Informationsdatei
  2. Anlegen eines neuen Besitzers der Datenbank
  3. Aktivieren des Anmeldekennworts für den neuen Besitzer, und neue Datenbank erstellen.
  4. Ändern des Besitzers, und Entziehung der Rechte für den bisherigen Besitzer
  5. Import aller Objekte aus der Ursprungsdatenbank


Schritt 1:
Neue Arbeitsgruppen-Informationsdatei (mdw-Datei) erstellen und an die neue Arbeitsgruppe anschließen

  1. Beende Microsoft Access.

  2. Zum Erstellen einer neuen mdw-Datei starte den Arbeitsgruppen-Administrator.
    Er ist z.B. zu finden im Verzeichnis: "C:\Programme\Microsoft Office\Office\1031\WRKGADM.EXE".

  3. Klicke im Dialogfeld Arbeitsgruppen-Administrator auf Erstellen.

  4. Gib im Dialogfeld Informationen zum Arbeitsgruppeneigentümer Deinen Namen und ggf. die Firma an, und gib für die Arbeitsgruppen-Identifikationsnummer (= geheimes Passwort) eine beliebige Kombination aus bis zu 20 Ziffern und Buchstaben ein.

    Achtung:
    Notiere Dir die genaue Schreibweise des Namens, der Firma und der Arbeitsgruppen-Identifikationsnummer, einschließlich der Groß-/Kleinschreibung (für alle drei Einträge), und bewahre diese Informationen an einem sicheren Ort auf. Wenn Du die Arbeitsgruppen-Informationsdatei neu erstellen musst, musst Du diese Informationen genau wie beim ersten Mal wieder eingeben. Du kannst diese Einträge, wenn Du sie vergißt oder verlierst, nicht wiederherstellen, und verlierst damit den Zugriff auf Deine Datenbanken.

  5. Gib einen Namen für die neue Arbeitsgruppen-Informationsdatei (mdw-Datei) ein, und klicke dann auf OK.
    (Wenn Du die Datei an einer anderen Stelle speichern möchtest, gib einen Pfadnamen ein, oder klicke auf Durchsuchen, um den neuen Pfad anzugeben).
    Klicke auf Beenden.

    Die neue Arbeitsgruppen-Informationsdatei wird beim nächsten Starten von Microsoft Access verwendet. Wenn weitere Benutzer an die in der neuen Arbeitsgruppen-Informationsdatei definierte Arbeitsgruppe angeschlossen werden sollen, lasse jeden dieser Benutzer zum Anschließen an die Arbeitsgruppen-Informationsdatei das Dienstprogramm Arbeitsgruppen-Administrator ausführen.


Schritt 2:
Anmeldekennwort aktivieren und neuen Administrator (Besitzer) anlegen

  1. Öffne Microsoft Access.

  2. Schließe das Popup-Fenster für das Erstellen einer neuen Datenbank, indem Du auf Abbrechen drückst.

  3. Öffne das Dialogfeld Benutzer- und Gruppenkonten über die Menüpunkte Extras - Sicherheit - Benutzer- und Gruppenkonten.

  4. Wähle den Benutzernamen Administrator aus und klicke auf Anmeldungskennwort ändern.

  5. Im folgenden Dialogfeld trägst Du in das Feld Altes Kennwort nichts ein.
    In das Feld Neues Kennwort trägst Du Dein gewünschtes Anmeldungskennwort ein.
    Im Feld Bestätigen wiederholst Du das Kennwort.
    Bestätige die Eingaben mit Übernehmen.

    Hinweis: Das Anmeldungskennwort des Administrators darf nie gelöscht werden, auch wenn es nicht verwendet wird, sonst besteht kein Zugang zur Datenbank.

    Achtung: Auch dieses Kennwort musst Du an einem sicheren Ort aufbewahren, da es ggf. für das Wiederherstellen der Arbeitsgruppen-Informationsdatei benötigt wird.

  6. Klicke auf Benutzer und dann auf Neu...
    Gib im Feld Name den Namen des von Dir gewünschten neuen Administrators und Besitzers der Datenbank ein. Das bist vermutlich Du selbst.
    Gib im Feld Persönliche ID ein Kennwort ein.
    Bestätige die Eingaben mit OK.

    Achtung: Auch dieses Kennwort musst Du an einem sicheren Ort aufbewahren, da es ggf. für das Wiederherstellen der Arbeitsgruppen-Informationsdatei benötigt wird.

  7. Klicke auf Hinzufügen, um die Gruppe Administratoren aus der Liste der Verfügbaren Gruppen in das Listenfeld Mitglied von zu kopieren, d.h. der neue Administrator (Besitzer) muss Mitglied der Benutzer und der Administratoren sein.

  8. Schließe das Dialogfeld mit OK.

  9. Schließe Access.


Schritt 3:
Anmeldekennwort für den neuen Administrator (Besitzer) aktivieren, und neue Datenbank erstellen.

  1. Öffne Access.

  2. Schließe das Popup-Fenster für das Erstellen einer neuen Datenbank, indem Du auf Abbrechen drückst.

  3. Öffne das Dialogfeld Benutzer- und Gruppenkonten über die Menüpunkte Extras - Sicherheit - Benutzer- und Gruppenkonten.

  4. Im folgenden Anmeldedialog gibst Du (statt Administrator) den Namen des in Schritt 2 angelegten neuen Administrators (Besitzers) der Datenbank ein. Das Feld Kennwort lässt Du leer.

  5. Klicke auf Anmeldungskennwort ändern, und ändere das Anmeldekennwort für den neuen Administrator (Besitzer), indem Du die Punkte 3 bis 6 in Schritt 2 für den Benutzernamen des neuen Administrators wiederholst.

  6. Schließe das Dialogfeld mit OK.

  7. Erstelle nun eine neue Datenbank, und speichere sie unter einem Namen ab.


Schritt 4:
Besitzer ändern, und den Gruppen "Administratoren" und "Benutzer" sämtliche Rechte entziehen

  1. Öffne das Dialogfeld Benutzer- und Gruppenberechtigungen über die Menüpunkte Extras - Sicherheit - Benutzer- und Gruppenberechtigungen.

  2. Klicke auf den Reiter Besitzer ändern.

  3. Wähle als Neuer Besitzer den von Dir neu angelegten Administrator (Besitzer) aus, und klicke auf Besitzer ändern.

  4. Klicke auf den Reiter Berechtigungen.

  5. Wähle unter dem Punkt Liste das Optionsfeld Benutzer aus, und kontrolliere nach, ob der alte Administrator keine Rechte mehr, aber der von Dir neu angelegte Administrator (Besitzer) alle Rechte an allen Objekten besitzt.

  6. Klicke das Optionsfeld Gruppen an, und lösche für die Gruppen Administratoren und Benutzer jeweils für alle im Kombinationsfeld Objekttyp angegeben Objekte sämtliche Berechtigungen durch Deaktivieren der entsprechenden Kontrollkästchen.

  7. Schließe das Dialogfeld mit OK.


Schritt 5:
Alle Objekte aus der ursprünglichen Datenbank importieren

  1. Öffne das Dialogfeld Importieren über die Menüpunkte Datei - Externe Daten - Importieren und importiere alle Tabellen, Abfragen, Formulare, Berichte, Seiten, Makros und Module aus der ursprünglichen, ungeschützten Datenbank.

  2. Passe die Verweise an die Verweise der ursprünglichen Datenbank an.
    Wechsle dazu in die Code-Ansicht und öffne den Dialog Extras - Verweise.